Zend - The PHP Company


Aggiornamento Zend Core per PHP 5.2.6

Zend ha rilasciato un nuovo aggiornamento per Zend Core 2.5 che include l'ultima versione di PHP, la 5.2.6, e una nutrita serie di miglioramenti. Questo aggiornamento è gratuto per chiunque abbia sottoscritto un contratto Zend Core support . Tra le novità:

- l'ultima versione stabile di PHP, la 5.2.6, che contiene oltre 120 correzioni di bug e risoluzioni ai problemi relativi alla sicurezza. Segnaliamo i principali:

  • corretto il potenziale stack buffer overflow in FastCGI SAPI
  • corretto overflow in printf()
  • corretto il problema di sicurezza descritto in CVE-2008-0599 (Common Vulnerabilities and Exposures)
  • corretto safe_mode bypass in CURL
  • corretto il problema relativo a multibyte char in escapeshellcmd()

- aggiornamento alla versione V.2.4 di Oracle oci8, che permette di supportare totalmente Oracle 11g, e inoltre miglioramenti e correzioni di problemi. Tra i principali:

  • correzione del bug PECL bug #10194 (crash nel client Oracle quando è raggiunto il limite di memoria nel callback)
  • permesso il settaggio della dimensione di cache per connessioni non persistenti
  • migliorato oci_password_change() per la chiusura di connessioni persistenti in fase di shutdown
  • cambiato oci_pconnect() in modo che si comporti come oci_connect() quando sono usati con i privilegi SYSDBA e SYSOPER


- l'aggiornamento Linux contiene l'ultima versione di OpenSSL (v0.9.8g), di CURL (7.18.1) e di Zend Optimizer (3.3.5).

Consigliamo a tutti di effettuare l'aggiornamento prima possibile, ciò garantisce un ambiente PHP ancora più affidabile.


Scarica gli aggiornamenti »

Acquista un abbonamento a Zend Core »