Zend - The PHP Company


Zend Guard 6.0

What's New

Changes in Zend Guard from version 5.5 to 6.0

  • Full support for PHP 5.4

Changes in Zend Guard from version 5.0.1 to 5.5

  • Full support for PHP 5.3

Changes in Zend Guard from version 5.0.0 to 5.0.1


  • Exclude resources support
Allows you to exclude files and folders from obfuscation (the resource will be copied as is to the output location without obfuscation and without encoding). Users can select a folder or a file and exclude it by selecting "Exclude resource" from the context menu.

 

  • Support for non English operating systems (i.e. Japanese)
A support for selecting non-English source folders and output folders was added. This feature was tested with Japanese operating system on Windows, Linux and Mac.

  • Documentation Help – Obfuscation
The obfuscation section (for greater protection of your code) and the scenarios that require using the Exclude list to overcome runtime errors that may result from obfuscation was reviewed and modified.

Changes in Zend Guard from version 4.1 to 5.0

This new major product update provided unprecedented code protection and an improved user experience. We've been working hard to bring new innovation to our product line, in order to provide better protection for your intellectual property. This new version increases protection during the encoding phase, thus making it harder to reverse-engineer your PHP applications.

A completely new GUI (graphical user-interface) provides unprecedented ease-of-use to the encoding process. You can now encode more efficiently and transparently, while keeping the application's performance optimal. 

Key Improvements:

  • PHP 5.2 Support
  • New User Interface – New UI based on Eclipse RCP technology for easy files management and control divided into different tabs of configuration:
    • Overview – Configure your application general information including optimization level, error handling and source options.
    • Security – Define encoded files expiration date, licensing configuration and obfuscation options.
    • Exclude list – Scan the files for suggested encoded files exclude list or select files manually.
    • Header information – Provide customized header information or user Zend Guard default header.
    • XML Editor – Customize Zend Guard configuration XML file manually.
  • Easy license management – New product license wizard with separate private key control and customized license information.
  • Wild cards support for exclude list
  • Variables support for easy file paths description
  • Encoded files lock mechanism
  • Line numbers removal option


NOTE: PHP 5 files that were encoded by this version of Zend Guard require Zend Optimizer 3.3 or greater in order to run. PHP files that were obfuscated by this version of the Zend Guard require the Zend Optimizer 3.0 or greater in order to run. The latest version of the Zend Optimizer is available here.

Resources
DATASHEET

Read more about Zend Guard features

more»